Page 2 of 2 FirstFirst 12
Results 26 to 31 of 31

Thread: CEL Throttle issue Speed 3

  1. #26
    Sr Member Thrizzl3's Avatar
    Join Date
    Jul 2008
    Age
    32
    Ride
    Subaru WRX
    Posts
    18,392
    Thanks
    430
    Thanked 500 Times in 260 Posts
    Mentioned
    265 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    It's a notorious issue on the gen 1. The TB actuator gets stuck and it trips the CEL putting the car into limp mode. Most common issue is the weather...more so during the colder months. My solution for this was to let the engine get up to temperature before shut it off. Once I turned it back on everything was back to normal.

  2. #27
    Newbie dadinho_nfg's Avatar
    Join Date
    Jul 2009
    Posts
    238
    Thanks
    0
    Thanked 1 Time in 1 Post
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    my 08 Speed3 with 47K km on it keeps throwing a p2006 code then disappears by itself and then comes back. today i drove it and it was off but it keeps coming on and off

    has anyone experienced this?
    Dadinho

  3. #28

    Join Date
    Mar 2009
    Location
    Kitchener
    Posts
    5,742
    Thanks
    213
    Thanked 1,156 Times in 643 Posts
    Mentioned
    295 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    Quote Originally Posted by dadinho_nfg View Post
    my 08 Speed3 with 47K km on it keeps throwing a p2006 code then disappears by itself and then comes back. today i drove it and it was off but it keeps coming on and off

    has anyone experienced this?
    http://www.mazdaspeedforums.org/foru...l-p2006-51239/

    TSB for it. Took me two seconds to google P2006 Mazdaspeed 3.
    - 2016 Lexus NX200t F Sport -
    - 2010 Mazdaspeed 3 Black Mica - SOLD -

  4. #29
    Newbie dadinho_nfg's Avatar
    Join Date
    Jul 2009
    Posts
    238
    Thanks
    0
    Thanked 1 Time in 1 Post
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    Thanks for the reply but I've read that and if you read that link there isn't much info.

  5. #30

    Join Date
    Mar 2009
    Location
    Kitchener
    Posts
    5,742
    Thanks
    213
    Thanked 1,156 Times in 643 Posts
    Mentioned
    295 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    Quote Originally Posted by dadinho_nfg View Post
    Thanks for the reply but I've read that and if you read that link there isn't much info.
    There's plenty...it's the VTCS misbehaving. There's dozens of threads out there about p2006 and the VTCS and ways to fix it.

  6. #31
    Newbie dadinho_nfg's Avatar
    Join Date
    Jul 2009
    Posts
    238
    Thanks
    0
    Thanked 1 Time in 1 Post
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: CEL Throttle issue Speed 3

    what I'm reading is VTCS delete. but also could be the solenoid - I'll need to take it in and figure out exactly what the problem is.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Downloading/Uploading Speed Issue
    By cyberscorpi0 in forum General Lounge
    Replies: 4
    Last Post: 02-05-2007, 03:12 PM
  2. Ongoing CEL issues
    By bDeE in forum Problems with the Mazda3
    Replies: 13
    Last Post: 06-14-2005, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •