Results 1 to 10 of 10

Thread: Another P2188 problem

  1. #1
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Another P2188 problem

    Hey guys you may have seen this pop up before, but through my travels and searching I couldn't find a thread with the same type of problem description or symptoms...
    To start off with I have a 99 MS3 with 0 mods and nearly 180k on it.
    The specific time when the code pops up is almost always if I stop and start the car, sometimes takes a few stops(like actually turn it off and get out for 5 mins). I also have been getting just garbage gas mileage... like worse than when I had a 99 Eclipse GSX... When I first got it a year and half ago it was getting about 400km to a tank now its getting 250km... if the sun is right and the planets are aligned. I don't seem to notice any lagging or power loss, I have heard it miss once or twice just a little blip now and then, nothing too crazy, and it idles great 700rpm.

    I pulled the code on the car and read the freeze frame data, and from what I gather my STFT and LTFT are way off for being at idle... not sure what they are supposed to be though. I do have a warranty for the car that covers quite a bit of stuff, but the deductible is 300$ and they have to find the issue first... so god knows how much that will cost. Just hoping someone can point me in the right direction before I just randomly start blowing money on this car. Thanks!!

    Fuel Sys 1 CL
    Fuel Sys 2 NA
    Calc Load 23.9%
    ECT (F) 192.2
    STFT % -8.6
    LTFT % -17.2
    Eng RPM 693
    Veh Speed 0
    Spark Adv(deg) 9.5
    IAT(F) 68.0
    MAF(lb/min) 0.3
    TPS(%) 12.5
    Run Time(sec) 259
    Fuel Pres(psi) 438.0
    Command EGR % 0.0
    Command EVAP%0.0
    Fuel lvl % 92.9
    Warmup DTC clr 0
    Clr Dist(miles) 5
    BARO(inHg) 28.3
    CAT Te 11(F) 1425.9
    PCU Volts 14.006
    LOAD value % 17.6
    EQ Ratio 0.988
    Rel TPS % 2.7
    Ambient(F) 64.4
    TPS B % 12.9
    ACC Pedal D % 7.8
    ACC Pedal E % 8.2
    Command TAC % 3.9

  2. #2
    Moderator Mr Wilson's Avatar
    Join Date
    Jan 2010
    Location
    Toronto
    Posts
    4,604
    Thanks
    1,275
    Thanked 687 Times in 374 Posts
    Mentioned
    223 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    Check plugs, clean mafia, check purge valve.

    Hopefully it's one over those and not something like injectors.
    0.000212524463 gigawatts

  3. The Following User Says Thank You to Mr Wilson For This Useful Post:

    VicMazSpeed3 (03-16-2016)

  4. #3
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    LOL I just looked up how to take off the intercooler... wow thats easy okay so I'll have a look at the sparks and clean the maf while i'm at it? is the purge valve super hard to get at? I'm not certain where it is... front of the engine near the rad? if its the injectors I have a full year to have the replaced (warranty) so it wouldn't be the end of the world I guess.

  5. #4
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    okay so sparks look pretty mint, so I doubt its them. The MAF however, 2 things one screw holding the sensor in is stripped and was easy to wiggle around and lift up a bit so air leak maybe? also the one side of the MAF sensor was black and coated in carbon or something not sure. So I'll get some MAF cleaner and a bigger screw to hold that sensor down. Thanks for the tips Mr Wilson!

  6. The Following User Says Thank You to VicMazSpeed3 For This Useful Post:

    Mr Wilson (03-17-2016)

  7. #5
    Newbie MAZDArati's Avatar
    Join Date
    Apr 2014
    Location
    toronto
    Posts
    205
    Thanks
    23
    Thanked 17 Times in 16 Posts
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    Hey Vic a little word of advice don't go crazy with the cleaning agent on the Mac because they are pretty fragile just in case it is not broken to begin with .
    Quote Originally Posted by VicMazSpeed3 View Post
    okay so sparks look pretty mint, so I doubt its them. The MAF however, 2 things one screw holding the sensor in is stripped and was easy to wiggle around and lift up a bit so air leak maybe? also the one side of the MAF sensor was black and coated in carbon or something not sure. So I'll get some MAF cleaner and a bigger screw to hold that sensor down. Thanks for the tips Mr Wilson!

  8. #6
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    I hate revive a really dead thread, but my car is doing this crap again. I pulled the freeze frame from the code and the numbers look near identical to when I pulled the code last summer. Now since then I've had the turbo replaced and most of the exhaust. Second cat delete and new downpipe/top cat and I've added a sri. I've check the purge valve and it seems fine. The only time it pulls the code is if I'm sitting at a light for more than 2 mins. Driving around I haven't noticed any change the behaviour of the car. The reason for the turbo swap is that the cat degraded and plugged caused massive back pressure and blew the turbo. Short story long I don't want to have to do this again in a couple years if the car is dumping fuel into the system. I'm kinda at a loss here.

  9. #7
    Sr Member Noisy Crow's Avatar
    Join Date
    Jan 2008
    Location
    Brampton
    Posts
    4,115
    Thanks
    3
    Thanked 37 Times in 29 Posts
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    The place to start is to think through the question: Is the engine really running rich or does the ECU *think* it is running rich? If it thinks it is running rich it should pull back fuel and run lean. If it is actually running rich it should be trying to pull back the fuel but can't. So, if it can't pull back fuel: Why? Bad / leaking injector? Damage to the injector harness? Bad ECU? Suggest getting someone with a proper scope with an amp clamp to measure the current ramps on the injectors.

    BTW, leaky MAF would cause the engine to run lean as there would be more air getting in that the ECU is accounting for.
    2008 Carbon Gray GT Sedan 5 Speed

  10. #8
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    Is there an easy way to test for a leaky injector or is it a shop kind of job. If it is a leaky injector then my extended warranty will cover it, I just don't want to send it into the shop looming for the cause, that gets expensive real quick. Also excuse my ignorance but is there a way to test the ecu as well or just replace it and see what happens? I'm kinda thinking it is trying to pull fuel but can't for some reason (based on the LTFT numbers) so I'd like to take a look at the injectors if possible.

  11. #9
    Sr Member Noisy Crow's Avatar
    Join Date
    Jan 2008
    Location
    Brampton
    Posts
    4,115
    Thanks
    3
    Thanked 37 Times in 29 Posts
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    Injector can be checked by putting a pressure gauge on the fuel rail and running the engine. If the pressure drops fairly rapidly after shutting off the engine you probably have a bad injector. Lots of YouTube vids on that sort of thing.

    Something you could try: with the engine running disconnect the electrical connector for each injector in turn. The engine should misfire. If it does not misfire (or misfires less) for one or more injectors that would indicate they are letting fuel through all the time.
    Last edited by Noisy Crow; 05-23-2017 at 11:08 PM.

  12. The Following User Says Thank You to Noisy Crow For This Useful Post:

    VicMazSpeed3 (05-24-2017)

  13. #10
    Noob
    Join Date
    Mar 2016
    Posts
    6
    Thanks
    2
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Another P2188 problem

    Quote Originally Posted by Noisy Crow View Post
    Injector can be checked by putting a pressure gauge on the fuel rail and running the engine. If the pressure drops fairly rapidly after shutting off the engine you probably have a bad injector. Lots of YouTube vids on that sort of thing.

    Something you could try: with the engine running disconnect the electrical connector for each injector in turn. The engine should misfire. If it does not misfire (or misfires less) for one or more injectors that would indicate they are letting fuel through all the time.
    That's awesome thanks for the tips I'll give it a whirl on my day off this weekend.

Similar Threads

  1. code p0126 and p2188
    By c01799999 in forum Mazda3 General Discussion
    Replies: 3
    Last Post: 02-19-2014, 08:33 PM
  2. Code P2188
    By funkdupspeed3 in forum MazdaSpeed 3 Forum
    Replies: 9
    Last Post: 12-03-2012, 05:12 PM
  3. P2188 - System too rich in bank 1
    By n00bMeiSter in forum Engine & Drivetrain
    Replies: 1
    Last Post: 09-09-2011, 12:52 PM
  4. I keep getting CEL P2188! HELP!!!
    By gar_lei in forum Performance
    Replies: 7
    Last Post: 09-19-2010, 08:19 AM
  5. CEL on (P2188)
    By DeLaY_NoMoRe in forum Problems with the Mazda3
    Replies: 4
    Last Post: 05-01-2008, 01:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •