Hello Guest, on July 19th Mazda Canada is hosting a celebration of 50 Years in Canada. The evnet runs from 3pm - 7pm, and is free to attend. Registration is required. There will be give aways, product displays, and a chance to interact with Mazda staff. More details including registration link 50th Anniversary Event
Results 1 to 10 of 10

Thread: Please help! P0300 and P0089

  1. #1
    Newbie Husam_93's Avatar
    Join Date
    Mar 2015
    Location
    Mississauga
    Posts
    57
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default Please help! P0300 and P0089

    Hey folks,

    As the title says, I'm having issues with my car during cold start ups. The car usually misfires until it gets a bit warm, then drives normal after. While I'm cruising, I get P0089 sometimes which stands for "Fuel pressure regulator 1 performance" for some odd reason. Autotech Hpfp seems to be hitting +1900psi in WOT and idles at 415-450 psi but sometimes drops between 260-300 when I downshift, then goes back up to normal psi. The misfires occurred in Cyl #1 first but I've been getting multiple/random misfires in the past two weeks. I have all supporting mods installed and this issue started after I got dyno tuned. I contacted @Fobio regarding this issue and he said Its not related to the tune at all and these codes come and go sometimes. I would appreciate any help possible to figure it out. Thanks !

  2. #2

    Join Date
    Mar 2009
    Location
    Kitchener
    Posts
    5,732
    Thanks
    213
    Thanked 1,149 Times in 639 Posts
    Mentioned
    294 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Quote Originally Posted by Husam_93 View Post
    Hey folks,

    As the title says, I'm having issues with my car during cold start ups. The car usually misfires until it gets a bit warm, then drives normal after. While I'm cruising, I get P0089 sometimes which stands for "Fuel pressure regulator 1 performance" for some odd reason. Autotech Hpfp seems to be hitting +1900psi in WOT and idles at 415-450 psi but sometimes drops between 260-300 when I downshift, then goes back up to normal psi. The misfires occurred in Cyl #1 first but I've been getting multiple/random misfires in the past two weeks. I have all supporting mods installed and this issue started after I got dyno tuned. I contacted @Fobio regarding this issue and he said Its not related to the tune at all and these codes come and go sometimes. I would appreciate any help possible to figure it out. Thanks !
    What a cop out of an answer from Fobio, I've yet to see a well tuned/running MS3 throwing codes randomly that come and go.

    That said, odds are he is right, it probably isn't the tune itself but consequences of an already weak component showing signs of failure when trying to run things more aggressively. I'd start by checking plugs for fouling and injectors/injector seals.
    - 2016 Lexus NX200t F Sport -
    - 2010 Mazdaspeed 3 Black Mica - SOLD -

  3. #3
    Newbie Husam_93's Avatar
    Join Date
    Mar 2015
    Location
    Mississauga
    Posts
    57
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Quote Originally Posted by SomeGuy View Post
    What a cop out of an answer from Fobio, I've yet to see a well tuned/running MS3 throwing codes randomly that come and go.

    That said, odds are he is right, it probably isn't the tune itself but consequences of an already weak component showing signs of failure when trying to run things more aggressively. I'd start by checking plugs for fouling and injectors/injector seals.
    I'll be getting a full system diagnoses to figure out what the issue could be. It's been frustrating me. I appreciate your input

    Sent from my Pixel using Tapatalk

  4. #4
    Newbie Como's Avatar
    Join Date
    Aug 2013
    Location
    Guelph
    Posts
    179
    Thanks
    1
    Thanked 23 Times in 14 Posts
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Hopefully it's something simple as just a bad spark plug or something(although the f/p drop seems odd). Good or bad depending on how you look at it, adding mods and building up more power highlight the weak points.
    2005 Mazda 3 hatch

    2006 MS6

  5. #5
    Newbie Husam_93's Avatar
    Join Date
    Mar 2015
    Location
    Mississauga
    Posts
    57
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Quote Originally Posted by Como View Post
    Hopefully it's something simple as just a bad spark plug or something(although the f/p drop seems odd). Good or bad depending on how you look at it, adding mods and building up more power highlight the weak points.
    That's what im hoping for. The plugs are brand new and i believe jimmy @Street Performance gapped them to 0.28. turbo and motor are both original with 61k only.


    Sent from my Pixel using Tapatalk

  6. #6
    Newbie Como's Avatar
    Join Date
    Aug 2013
    Location
    Guelph
    Posts
    179
    Thanks
    1
    Thanked 23 Times in 14 Posts
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    You going back to jimmy to have it looked over?
    He should be able to determine your issue. If you can't get into see him for a bit there is the option of posting on msf forum and ask there. Not sure if you're on there. Be forewarned though about posting there if you don't research first. They're pretty hard core and will troll you hard for posting something that's been covered before.
    I've had really good luck (knock wood) with my ms6. Self tuning is going well but I too am also in the midst of chasing an unmetered air leak that's really pissing me off.

    Good luck!!


    Sent from my iPhone using Tapatalk

  7. #7
    Newbie Husam_93's Avatar
    Join Date
    Mar 2015
    Location
    Mississauga
    Posts
    57
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Quote Originally Posted by Como View Post
    You going back to jimmy to have it looked over?
    He should be able to determine your issue. If you can't get into see him for a bit there is the option of posting on msf forum and ask there. Not sure if you're on there. Be forewarned though about posting there if you don't research first. They're pretty hard core and will troll you hard for posting something that's been covered before.
    I've had really good luck (knock wood) with my ms6. Self tuning is going well but I too am also in the midst of chasing an unmetered air leak that's really pissing me off.

    Good luck!!


    Sent from my iPhone using Tapatalk
    I'll do system diagnosis first then go to jimmy if something needs to be replaced. That forum is pretty active but i got no time to waste on trolls lol. Well, i wish you all the best sir. Thanks!

    Sent from my Pixel using Tapatalk

  8. #8
    Jr Member Karmaspeed's Avatar
    Join Date
    Oct 2008
    Location
    Pickering
    Posts
    474
    Thanks
    5
    Thanked 57 Times in 41 Posts
    Mentioned
    45 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Try loading the ots map on your ap and see if the less aggressive tune eliminates the symptoms. If it does then you can go from there for your trouboshooting and you can at least drive the car code free

  9. #9
    Newbie Husam_93's Avatar
    Join Date
    Mar 2015
    Location
    Mississauga
    Posts
    57
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Quote Originally Posted by Karmaspeed View Post
    Try loading the ots map on your ap and see if the less aggressive tune eliminates the symptoms. If it does then you can go from there for your trouboshooting and you can at least drive the car code free
    I thought about doing that but my car started fine with no hesitation or misfiring at all. I've been having this issue for nearly a month and it just disappeared. However, i'm still going to look into the issue and determine the cause. I'll keep your advice in mind, thank you!


    Sent from my Pixel using Tapatalk

  10. #10
    Noob
    Join Date
    Mar 2017
    Posts
    25
    Thanks
    1
    Thanked 1 Time in 1 Post
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Please help! P0300 and P0089

    Just curious what was causing the issues. Any info should be a good future reference.

Similar Threads

  1. Codes - P0139 & P0300
    By S.F.W. in forum MazdaSpeed 3 Forum
    Replies: 17
    Last Post: 04-19-2015, 03:03 PM
  2. 07 mazda 3 p2004 and p0300 after miss shift
    By hammy in forum Problems with the Mazda3
    Replies: 16
    Last Post: 09-02-2011, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •