Results 1 to 3 of 3

Thread: Key fobs won't work but key does?

  1. #1
    Noob
    Join Date
    May 2014
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Key fobs won't work but key does?

    Hi! My key fob stopped working. Thought it might be the battery so I tried my backup one and discovered that it didn't work either. The regular key works instead for now but does that mean it's a sensor issue or something?

  2. #2
    Noob
    Join Date
    Dec 2013
    Posts
    30
    Thanks
    0
    Thanked 8 Times in 7 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Key fobs won't work but key does?

    Do you have the keyless entry/exit?

    I went through this myself just recently with our 2014 3 GT. Wife was complaining that her fob was becoming non-functional, and died completely pretty quickly after that. Like you, I assumed it was the battery and swapped her fob with the spare, which had been only seldomly used since we bought the car (new).

    On a whim, I replaced the battery anyway. And sure enough, both fob batteries had died at almost the exact same time; the one used daily, and the one that spent most of its like on the "spares" hook. Replaced the other, and now both work fine.

    My theory is that with the whole proximity sensor thing (keyless entry/exit) the fob is transmitting a weak RF signal almost constantly. From reading further, it's a bit more complicated than that, but the gist is that even the "spare" fob will transmit every now and then. Unless you push the buttons on the fob itself often, both will discharge at roughly the same rate.

    TL;DR: Replace the battery before troubleshooting any further. Can't possibly hurt, may solve.

    Brad.

  3. #3
    Noob
    Join Date
    May 2014
    Posts
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Key fobs won't work but key does?

    Quote Originally Posted by bpsmicro View Post
    Do you have the keyless entry/exit?

    I went through this myself just recently with our 2014 3 GT. Wife was complaining that her fob was becoming non-functional, and died completely pretty quickly after that. Like you, I assumed it was the battery and swapped her fob with the spare, which had been only seldomly used since we bought the car (new).

    On a whim, I replaced the battery anyway. And sure enough, both fob batteries had died at almost the exact same time; the one used daily, and the one that spent most of its like on the "spares" hook. Replaced the other, and now both work fine.

    My theory is that with the whole proximity sensor thing (keyless entry/exit) the fob is transmitting a weak RF signal almost constantly. From reading further, it's a bit more complicated than that, but the gist is that even the "spare" fob will transmit every now and then. Unless you push the buttons on the fob itself often, both will discharge at roughly the same rate.

    TL;DR: Replace the battery before troubleshooting any further. Can't possibly hurt, may solve.

    Brad.
    Thanks Brad! I'll try replacing the battery tomorrow. Hoping it works because that'd definitely be easier!

Similar Threads

  1. Will this work?
    By Dyno in forum I.C.E (In-Car Entertainment)
    Replies: 15
    Last Post: 02-09-2012, 10:48 AM
  2. Key Fobs Won't Work After New PJB
    By RedRaptor in forum Lighting, Electrical & Security
    Replies: 11
    Last Post: 07-20-2009, 04:14 PM
  3. Programing Key fobs...
    By webb70 in forum Mazda3 General Discussion
    Replies: 9
    Last Post: 02-24-2007, 10:28 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •