My OEM remote start has stopped working on my 2007 Mazda 3 GT with Auto transmisssion. When I press lock and start on the fob, the lights come on and it tries to start the car but the engine doesn't crank. I have noticed that when it does this, the theft link blinks rapidly which led me to think that the immobilizer is the issue. I then took my key while sitting in the car and held the black pastic part of the key containing the chip right beside the key tumbler and tried to start the car with the remote start and it started. I then tried to restart it without the key beside the tumbler and it worked a few times but the next morning it stopped working until I had the key near the tumbler again. If I take the steering column apart do you guys think I can fix it by playing with the immobilizer ribbon around the key tumbler or more than likely the immobilizer module is the issue and I would need to order a new one to replace it? I have attached the installation instructions for this remote start but it was originally installed by my dealer when I bought the car in 2007.

I also tried to do the immobilizer program procedure from the instruction manual and it didn't change anything. I disconnected the negative battery terminal, turn the key to the on position, reconnected the battery cable and then turned the key to off and then started the car with the key and then turned it off. I then put key 1 into ignition and turned it to the on position and waited for the theft light to turn off and turned key to off and removed it. Within 5 seconds I inserted key 2 and turned to on until theft light turned off and turned key to off and removed. I then tried to start the car with the remote start but the lights and blower motor can on but the theft light blink rapidly telling me the immobilizer is not working.

The other thing I never figured out prior to having this issue when the system was working as it used to, is that when I start the car it triggers the alarm. The only way I found around this is that I send the remote start command with the fob and as soon as I am done I press unlock to deactivate the alarm and then it doesn't go off once started. I don't think it should work this way but I am unsure why the remote start would trigger the alarm. The immobilizer signal must work since it let the car started. Maybe the shock sensor is triggering the alarm? I don't know if the dealer configured the sensor but when I looked under the dash I seen it there.

Remote start install instructions are at this link: