Results 1 to 13 of 13

Thread: Car stalling after new battery installed

  1. #1
    Jr Member Hotsky's Avatar
    Join Date
    Oct 2012
    Location
    Hamilton
    Age
    34
    Posts
    594
    Thanks
    5
    Thanked 8 Times in 8 Posts
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default Car stalling after new battery installed

    Last weekend my battery died got a new one installed and while driving to work next day car stalls twice! First thought was looks like my alternator is going. I was about to shell out the cash on the new one, but heard Parts Source stores do a free battery/alternator test. Got it done expecting the guy to tell me its the alternator, but nope everything works well! Ok now what? So I did some research and looks like rough idle and stalling is a thing after battery is disconnected, at least on early Mazda 3's. Apparently ECU is relearning how to function all over again, but I dont remember this happening 4 years ago when i replaced the battery! After driving for a week just to work and back 10-11km trip I would get 1-3 stalls when i'm at complete stop at a light or sitting in traffic. But today it dies while I was making a turn, luckily I was able to cost it across the street and there was no incoming traffic. So I decided to disconnect the battery wait a min and hook it up again and let it idle for a bit than went to for a drive and it stalled again WHILE costing to a red light, this doesn't even feel safe anymore and idk what to do. Whats going on with it? My car is a 2005 Mazda 3 automatic. no CEL
    Last edited by Hotsky; 01-13-2018 at 11:03 PM.

  2. #2

    Join Date
    Mar 2009
    Location
    Kitchener
    Posts
    5,710
    Thanks
    212
    Thanked 1,133 Times in 633 Posts
    Mentioned
    287 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Loose connection somewhere...check not just the connections at the battery but the wires to ground (should be on top of the strut tower), wires to the alternator, wires to the ECU/fuse box, and anything else that would have been disturbed when pulling the battery.
    - 2016 Lexus NX200t F Sport -
    - 2010 Mazdaspeed 3 Black Mica - SOLD -

  3. #3
    Armchair Detailer Jackal's Avatar
    Join Date
    Jul 2010
    Location
    Richmond Hill
    Ride
    2012 Porsche 911
    Posts
    8,146
    Thanks
    1,341
    Thanked 966 Times in 634 Posts
    Mentioned
    131 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Also check throttle body. Best to bring it to trusted mechanic. Donít drive it like that.


    Sent from my iPhone using Tapatalk

  4. #4
    Sr Member Noisy Crow's Avatar
    Join Date
    Jan 2008
    Location
    Brampton
    Posts
    4,134
    Thanks
    3
    Thanked 42 Times in 33 Posts
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Also check the connections between the alternator and the rest of the car. Especially ground straps. The car should be able to run fine on just the alternator only. Also have the power steering pump checked. They are electric on these cars, and a failing pump could be drawing excess current. A good mechanic will also check fuel pressure, etc. to rule out any issues with other systems. While it is very likely the issue is electrical it could just be a coincidence that the problem started when you changed the battery. May be the battery was okay but the actual problem was draining the battery.
    Last edited by Noisy Crow; 01-14-2018 at 02:33 PM.
    2008 Carbon Gray GT Sedan 5 Speed

  5. #5
    Newbie
    Join Date
    Dec 2006
    Posts
    217
    Thanks
    1
    Thanked 7 Times in 7 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Happened to my 2007, after I changed the battery... it took about 1-2 weeks for the car to be back to normal. On my 2015 I had no issues like that, my battery died a few weeks ago and it worked fine after I charged it.
    [SIGPIC][/SIGPIC]

  6. #6
    Member sarujo's Avatar
    Join Date
    Jun 2010
    Location
    GTA
    Posts
    1,289
    Thanks
    72
    Thanked 79 Times in 60 Posts
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by Hotsky View Post
    Last weekend my battery died got a new one installed and while driving to work next day car stalls twice! First thought was looks like my alternator is going. I was about to shell out the cash on the new one, but heard Parts Source stores do a free battery/alternator test. Got it done expecting the guy to tell me its the alternator, but nope everything works well! Ok now what? So I did some research and looks like rough idle and stalling is a thing after battery is disconnected, at least on early Mazda 3's. Apparently ECU is relearning how to function all over again, but I dont remember this happening 4 years ago when i replaced the battery! After driving for a week just to work and back 10-11km trip I would get 1-3 stalls when i'm at complete stop at a light or sitting in traffic. But today it dies while I was making a turn, luckily I was able to cost it across the street and there was no incoming traffic. So I decided to disconnect the battery wait a min and hook it up again and let it idle for a bit than went to for a drive and it stalled again WHILE costing to a red light, this doesn't even feel safe anymore and idk what to do. Whats going on with it? My car is a 2005 Mazda 3 automatic. no CEL
    Clean the MAF sensor and throttle body and then do an ECU reset. Pull the negative battery wire and press the brake pedal a few times to drain completely. Reconnect the battery and let idle for a good 10 to 15 minutes and then take it for a nice drive.

    Crud build-up on the MAF and throttle body make it difficult for relearning to occur, especially on older models. Cleaning both makes it easier for this to occur. Give it a try and let us know.
    Last edited by sarujo; 01-19-2018 at 11:22 PM.


    2010 Sport 2.0L 5MT

  7. #7
    Jr Member Hotsky's Avatar
    Join Date
    Oct 2012
    Location
    Hamilton
    Age
    34
    Posts
    594
    Thanks
    5
    Thanked 8 Times in 8 Posts
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Thanks for the reply's guys. After I posted here next day I let the car idle for close to 10 mins heat, radio off than turned the heat on and idled for a bit longer after that I had one time when RMP's just jumpy at a stop light panel flashed but car didn't stall. After that for a week now I have had no issues and the idle is pretty smooth again. If I had gotten another stall or bad case of rough idle next step was to clean the throttle body and MAF sensor as sarujo suggested (I've done that once maybe 4-5 years ago when I installed my short ram air intake).

  8. #8
    Member sarujo's Avatar
    Join Date
    Jun 2010
    Location
    GTA
    Posts
    1,289
    Thanks
    72
    Thanked 79 Times in 60 Posts
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by Hotsky View Post
    Thanks for the reply's guys. After I posted here next day I let the car idle for close to 10 mins heat, radio off than turned the heat on and idled for a bit longer after that I had one time when RMP's just jumpy at a stop light panel flashed but car didn't stall. After that for a week now I have had no issues and the idle is pretty smooth again. If I had gotten another stall or bad case of rough idle next step was to clean the throttle body and MAF sensor as sarujo suggested (I've done that once maybe 4-5 years ago when I installed my short ram air intake).
    Glad things have stabilized. 4 or 5 years is a long time thou - the MAF and TB will be dirty. I do mine annually now since it's so easy on these cars. Maybe you can squeek in the cleaning + reset while the temps are above zero!

  9. #9
    Sr Member Flagrum_3's Avatar
    Join Date
    May 2005
    Location
    Scarborough
    Posts
    6,154
    Thanks
    333
    Thanked 323 Times in 257 Posts
    Mentioned
    96 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by sarujo View Post
    Glad things have stabilized. 4 or 5 years is a long time thou - the MAF and TB will be dirty. I do mine annually now since it's so easy on these cars. Maybe you can squeek in the cleaning + reset while the temps are above zero!
    Haven't touched my MAF or TB in 12.5 years and have had zero issues with idling or any issues whatsoever (knock on wood). Maybe its the choice of gas or maybe the fact I used a fuel system cleaner every oil change period, don't know, but seriously no issues and I drive mostly city.


    @Hotsky -As for your issue, I've had my battery disconnected many times and even when I finally had to replace my battery, I never had any 'learning' issues. I'd just start the car, drive it for 20-30 minutes and everything would be fine. I'm wondering (even though it seems fine now), if there might be a ground issue. The car is old, its bound to have corrosion, especially the 1st generation Mazda's.


    _3
    Last edited by Flagrum_3; 01-20-2018 at 11:44 PM.

  10. #10
    Member sarujo's Avatar
    Join Date
    Jun 2010
    Location
    GTA
    Posts
    1,289
    Thanks
    72
    Thanked 79 Times in 60 Posts
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by Flagrum_3 View Post
    Haven't touched my MAF or TB in 12.5 years and have had zero issues with idling or any issues whatsoever (knock on wood). Maybe its the choice of gas or maybe the fact I used a fuel system cleaner every oil change period, don't know, but seriously no issues and I drive mostly city.


    @Hotsky -As for your issue, I've had my battery disconnected many times and even when I finally had to replace my battery, I never had any 'learning' issues. I'd just start the car, drive it for 20-30 minutes and everything would be fine. I'm wondering (even though it seems fine now), if there might be a ground issue. The car is old, its bound to have corrosion, especially the 1st generation Mazda's.


    _3
    Wow...bet your car would pull better after doing both MAF and TB! The TB will always build up an oily mess behind the butterfly plate thanks for the PCV venting into the intake. The edges of the butterfly plate build up a dark carbon residue which over time causes idles issues. At least the MAF is upstream from this so it doesn't get as dirty as quickly, although in my experience, using oiled filters will dirty up the MAF faster.

    I too use a fuel sytem cleaner (Redline SI-1 - lots of PEA in that formulation) every 10k or so and have had very good results with this regimen, but a fuel additive will only help with cleaning combustion chambers, valves etc and not the TB. Knock that wood, baby!
    Last edited by sarujo; 01-21-2018 at 12:17 AM.

  11. #11
    Sr Member Flagrum_3's Avatar
    Join Date
    May 2005
    Location
    Scarborough
    Posts
    6,154
    Thanks
    333
    Thanked 323 Times in 257 Posts
    Mentioned
    96 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by sarujo View Post
    Wow...bet your car would pull better after doing both MAF and TB! The TB will always build up an oily mess behind the butterfly plate thanks for the PCV venting into the intake. The edges of the butterfly plate build up a dark carbon residue which over time causes idles issues. At least the MAF is upstream from this so it doesn't get as dirty as quickly, although in my experience, using oiled filters will dirty up the MAF faster.

    I too use a fuel sytem cleaner (Redline SI-1 - lots of PEA in that formulation) every 10k or so and have had very good results with this regimen, but a fuel additive will only help with cleaning combustion chambers, valves etc and not the TB. Knock that wood, baby!
    My car pulls fine, actually feels better then ever and gets pretty good mileage also...

    Your throttle body, butterfly plate etc will build carbon residue in just a few thousand kilometers, if that. As I said 320k of city mileage with no issues, and I really don't expect any. Honestly I think the whole MAF/TB thing is overdone and overplayed.


    _3
    Last edited by Flagrum_3; 01-21-2018 at 01:05 PM.

  12. #12
    Jr Member baymoe's Avatar
    Join Date
    Feb 2007
    Location
    Markham
    Posts
    901
    Thanks
    3
    Thanked 27 Times in 17 Posts
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Quote Originally Posted by Flagrum_3 View Post
    My car pulls fine, actually feels better then ever and gets pretty good mileage also...

    Your throttle body, butterfly plate etc will build carbon residue in just a few thousand kilometers, if that. As I said 320k of city mileage with no issues, and I really don't expect any. Honestly I think the whole MAF/TB thing is overdone and overplayed.


    _3
    Agreed. Cleaning them did jack squat for my vehicle. Did it the few times I changed my air filter. If it makes you feel any better to clean it, by all means.

    Back to what the OP is experiencing. It's most likely the ECU relearning. It usually cures itself after spirited driving (high revs).
    |-----> Roof Rack <-----| Thule Base Rack - Rocky Mounts Bike Tray - Thule Ski Holder
    2007 GT Sedan 5spd CWP | Rays Mazdaspeed Wheels | Tri-Point Engineering Rear Swaybar
    SPC Camber Links | Bilstein Coilovers | Tint | LED Brake

  13. #13
    Jr Member
    Join Date
    Oct 2008
    Posts
    498
    Thanks
    1
    Thanked 38 Times in 34 Posts
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Car stalling after new battery installed

    Cleaning the MAF sensor has a high probability of messing it up. Know what you're doing, and use right kind of cleaners that leave NO residue. Or better yet, leave the MAF alone unless the sensor is malfunctioning.

    Been burned in late 90s / early 00s on two of my cars when I tried MAF cleaning on a car that functioned just fine.

Similar Threads

  1. Oil light on after stalling
    By ZimZamTheFlimFlam in forum Engine & Drivetrain
    Replies: 3
    Last Post: 03-16-2017, 05:09 PM
  2. Help, Car is stalling intermittently.
    By Rob Bruno in forum MazdaSpeed 3 Forum
    Replies: 12
    Last Post: 11-26-2014, 01:28 PM
  3. STALLING PROBLEM
    By Lileminem in forum Mazda3 General Discussion
    Replies: 4
    Last Post: 10-08-2014, 12:56 AM
  4. ATX Stalling?
    By mido in forum Engine & Drivetrain
    Replies: 5
    Last Post: 10-28-2009, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •