Results 1 to 2 of 2

Thread: Weird AC fan issue

  1. #1
    Noob
    Join Date
    Jul 2019
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Weird AC fan issue

    Hey there, I have a weird problem with the AC fan and AC light/button.

    Turning on the AC and the light comes on the AC button as it should... Fan settings 1,2&3 do not work at all. Fan setting 4 works fine but when it's clicked to setting 4 the AC button automatically shuts off.

    To summarize : AC technically works because leaving it on settings 1,2 or 3 its cold but not blowing the cold air because fan is off. Clicking to 4 blows the cold air out momentarily but then it goes stale warm because AC switch automatically gets shut off.

    Hopefully someone can help. Thanks so much!

  2. #2
    Noob
    Join Date
    Aug 2019
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Weird AC fan issue

    Quote Originally Posted by Mr.Clean16 View Post

    To summarize : AC technically works because leaving it on settings 1,2 or 3 its cold but not blowing the cold air because fan is off. Clicking to 4 blows the cold air out momentarily but then it goes stale warm because AC switch automatically gets shut off.

    Hopefully someone can help. Thanks so much!
    Blower motor resistor/relay. It's melted or otherwise not working. You can test your actual A/c is working with an infared temp gun if you had one. Or FLIR (Hey it's not that expensive anymore)

    Make sure if you mess with it, or anyone for that matter, disconnect the battery. Might just need some CRC contact cleaner. Rust + corrosion is brutal for electronics on these cars.

Similar Threads

  1. Weird Transmission Issue ??
    By Mazda Lew in forum Mazda3 General Discussion
    Replies: 4
    Last Post: 04-19-2017, 10:41 PM
  2. Had a weird issue this morning
    By Jordan1200 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 06-02-2016, 04:01 PM
  3. Weird clicking/knocking sound..maybe someone's had same issue?
    By MDMaz3 in forum Problems with the Mazda3
    Replies: 4
    Last Post: 05-11-2014, 09:49 PM
  4. Weird Issue (CEL, Stalling)
    By sudz in forum Engine & Drivetrain
    Replies: 15
    Last Post: 08-06-2013, 06:25 PM
  5. Weird issue
    By Iceman_F1 in forum Site/Server issues and suggestions
    Replies: 8
    Last Post: 03-21-2009, 02:19 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •