Results 1 to 3 of 3

Thread: Possible issue with transmission?

  1. #1
    Noob
    Join Date
    Nov 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Possible issue with transmission?

    Hello,

    Just wanted to get some feedback as to recent issues I have been having with 2012 Mazda 3 GS automatic. Firstly, car would not recognize it was in park (light does not illuminate on the dashboard) and as a result it would only start in neutral. Googling around told me this was a relatively common issue and didnt seem too serious. Recently though a family member had an issue where the car stalled out? (not exactly sure here) going from reverse to drive, and somehow got the car stuck in drive, engine off. I was able to get it back into park and all seemed OK, but then that night, parked on a slight grade and the car began to reverse in park with a clicking sound. Admittedly I dont typically use the e brake when parking (guess I am paying for that) which apparently can be a cause. So my question is, does this seem like an issue with the transmission? If so, how serious? Apologies if my description is not great as I am not the most knowledgeable car owner. Thank you for any help.

  2. #2
    Jr Member MikeTheCheek's Avatar
    Join Date
    Sep 2013
    Location
    Mississauga
    Posts
    372
    Thanks
    142
    Thanked 135 Times in 90 Posts
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Possible issue with transmission?

    Neutral sensor switch.

  3. #3
    Newbie zoom4106's Avatar
    Join Date
    Dec 2009
    Location
    416
    Posts
    196
    Thanks
    2
    Thanked 2 Times in 2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Possible issue with transmission?

    Happened to me exactly same problem car won't start on park only on neutral, I just spray WD40 on the rusty switch and never happen again

Similar Threads

  1. Transmission Issue?
    By Jenuine in forum Engine & Drivetrain
    Replies: 5
    Last Post: 11-06-2014, 01:46 AM
  2. MK4 Auto Transmission issue - huh?
    By The Wolf in forum Other Cars
    Replies: 4
    Last Post: 03-10-2014, 08:31 PM
  3. Transmission issue?
    By Hotsky in forum Mazda3 General Discussion
    Replies: 9
    Last Post: 01-23-2014, 11:13 AM
  4. 07 Mazda 3 GT Transmission Issue
    By mercury6 in forum Problems with the Mazda3
    Replies: 6
    Last Post: 10-22-2013, 01:49 AM
  5. Help! Got an issue with either transmission or Clutch
    By jaimie08mazda3 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 06-22-2013, 01:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •